HEC-RAS Version 5.0 beta Issue with HDF5 Viewer

Written by ironcore | May 30, 2014

A few testers have discovered a dll conflict when trying to open the new 5.0 beta version of HEC-RAS.  The following message appears:


This happens if you’ve installed the HDF5 Viewer as described in the new “Combined 1D and 2D Modeling with HEC-RAS” document on page 115.

HDF5 is a new file format used by HEC-RAS to store 2D output as well as some 1D output (in addition to the standard output files and dss files).  The HDF5 file contains more output information than is currently available in the HEC-RAS graphics and tables, such as velocity information for cell faces and face points.  The HDF5 Viewer is currently the only way for users to access the 2D velocity output.

The issue is resolved by uninstalling the HDF5 Viewer.  HEC will be posting an updated install soon that corrects this problem.


  1. Spring XU

    on December 9, 2015

    Hi, Chris, First I would like to say thank you very much for your posts regarding HEC-RAS modeling/issues. They did help me a lot in the past.
    I wonder how to uninstall HDF5 viewer. I did not find its uninstall program. simply removing them seems not work. I greatly appreciate if you can help.
    Thank you!

  2. Luis Carlos

    on August 23, 2019

    Hi. I am experiencing the following error using version 5.0.7: HEC RAS is not able to recover geometry data from the HDF file.
    In RAS Mapper, I import the MDT and it goes smoothly in the Geometry window of HEC RAS. Then, I edit the different layers (rivers, banks, etc.) in RAS Mapper. Apparently everything is going well, but when I'm going to save the geometries, an error always appears. Of course, the layers are not seen in the Geometry window of HEC RAS, it is as if they were empty. The error says: "Error reading geometry data from file: path/*.HDF"
    I have tried on different computers and with different versions of Windows. Does anyone know how to solve it?
    Regards, thank you very much.

  3. Luis Carlos

    on August 27, 2019

    I have managed to solve the problem:

    At first, I was importing river geometries from SHP files generated in ArcGIS; well, I think this operation was producing some topological errors, for example in junctions. By editing the river layer directly in RasMapper with identical paths to those present in the SHP files, the problem has been solved. I can now properly save the g01.hdf file with all the geometries (banks, flowpaths, etc.) and continue the work without this problem.

Add Your Comment

Related Posts