2D Mesh “Leaking”

Written by ironcore | March 4, 2015

To follow up my post on fragmented inundation, I want to highlight another 2D mesh issue we should all be aware of.  Unlike fragmented inundation, which is an artifact of how HEC-RAS discretizes the 2D domain and the way it maps the results, Leaking is a result of terrain features not aligning with cell faces and/or cells that are too large, and can produce very wrong results.
Take the following example of leaking.


Here we see a high ground feature that is straddled by rather large cell.  HEC-RAS will preserve the underlying terrain on the cell faces, but the cell itself is resolved to a volume-elevation curve.  Since the high ground feature runs diagonally through the cell, it is not picked up by the cell faces.  As a result, HEC-RAS does not know that there is a barrier that should keep water on one side of the high ground feature before it is overtopped.  The consequence is that water leaks through the high ground and is available to move further down the channel even before the high ground is overtopped.  This is incorrect.  To better capture the high ground feature, cell faces in this vicinity should be aligned to the high ground feature so that the terrain is picked up on the cell faces, which will prevent leakage.  The following figure shows the resulting flood map at the same time in the simulation as the figure above.


Here we see the entire mesh has been overall refined to a smaller cell center spacing, but in addition, much more resolution was added by manually straddling cell centers around the high ground feature.  Notice around the crest of the high ground feature, the cell centers were placed to align the cell faces with the contours.  This ensures that the high ground is picked up by the cell faces.  The result is a higher resolution flood map, but also, and more importantly prevents leakage through the high ground before it is overtopped.  Also important is to provide much smaller cells on the downstream slope of the high ground feature, to prevent fragmented inundation.  In hindsight, I probably went a little overkill on adding cell centers, but it didn’t really add any noticeable time to the simulation, so I’m good with it.
Manually adding cell centers is not particularly precise, and can take a bit of time.  Fortunately HEC will be including a new feature in the full release of 5.0 that allows the user to define a breakline along high ground terrain features like this.  The mesh is then generated, automatically aligning the cell faces to that breakline.


  1. Anonymous

    on March 5, 2015

    Chris – Nice presentation of a fundamental problem. Agree, the Breakline should help us with the mesh generation. Vern

  2. Anonymous

    on March 5, 2015

    Chris – Nice presentation of a fundamental problem. Agree, the breakline feature should help us avoid this problem. Vern

  3. Chris Goodell

    on March 5, 2015

    Thanks Vern!

  4. Anonymous

    on February 13, 2017

    Hi Chris,
    I started to use HEC-RAS 5.0.3. two weeks ago, so I'm new at this. I have few questions for you. Is there any way to add breakline except manually? Can I perhaps export Contours from RAS Mapper and add them as breaklines?
    The second question is about the stability of the model. Can I anywhere check how big is the Courant number? I'm confused with one thing. If I understood this correctly, for the stability, I need a bigger grid and smaller computation time (so that the Courant number is around one), but in areas where I have leaking, I need to use a smaller grid to describe the higher ground (that means that the Courant number will be bigger than one). How will that reflect on the stability of my model?


  5. Chris Goodell

    on February 13, 2017

    You can import coordinates for breaklines in the GIS Tools menu item. The Courant number will change through out your mesh as mesh resolution changes and velocity changes. You should focus on the most restrictive (i.e. highest velocity areas and smallest cell center spacing).

  6. Anonymous

    on February 16, 2017

    Hi Chris,
    First of all, thank you for your answers. However, I still have a problem with my model. I succeed to import shapefile with contour lines from GIS as brakelines. My cell has mesh size 0.4×0.4 meters and my computation time is 0.1 second. The elevation difference between the contour line is 0.05 meters. As you can see I tried to describe my terrain as better as I can. I do not have a problem with high terrain than with the steep slope (slope is 1: 2). When I run the model, results show alternately and suddenly wetting and drying of the cells at the slope. I tried to use both equations (Diffusion Wave and Full Momentum), but the results are similar. Do you know what might be the issue or what I am doing wrong?

  7. Chris Goodell

    on February 22, 2017

    Sounds like either your getting fragmentation in the inundation or your model is unstable. Make sure you are targeting a Courant number close to 1 and when you map the inundation, check your settings under "Render Mode Options".

Add Your Comment

Related Posts